Er mogen op dit forum GEEN verzoekjes of requests gevraagd worden, dit staat ook in de regels die je accepteert bij het registreren op dit forum, hiervoor krijg je direct een permanente ban.

Spotlite onder Debian

Oude of gesloten topics van spot-net.nl vind je hier!

Moderator: Moderator Team

Gebruikersavatar

OP
nom001
Berichten: 13
Lid geworden op: 01 mar 2011, 21:04
Cash on hand: Locked
Reputation: 0
Usenet: NewsXS
Internet: KPN
Locatie: /home/nomko
Has thanked: 2 times
Leeftijd: 43

Spotlite onder Debian

Bericht door nom001 » 01 mar 2011, 21:08

Hoi,

Ben net nieuw hier, overgestapt van OpenFTD (onder Ubuntu en daarna onder Debian).
Heb dus via het forum van FTD deze site leren kennen.
En nu kom ik gelijk ook met een vraag: Heeft iemand hier Spotlite werkend gekregen onder Debian Stable?
Alvast bedankt!
nom001
*ASUS P5KPL-AM SE*Intel Quad CPU Q8200*4 GiB ram*nVidia GeForce 9500GT*Realtek RTL8101/8102E*RaLink RT2500 802.11g*Optiarc DVD RW AD-7200A*HDD:Samsung HD501LJ/HD103SI*Linux Mint 18*

Advertisement
Neem je online privacy serieus en gebruik een VPN verbinding!

Met een VPN verbinding van IPVanish wordt uw gehele internet verbinding versleuteld

U kunt dus veilig browsen, Torrents downloaden, Usenet downloaden en onderling versleutelde verbindingen opzetten.


Gebruikersavatar

Darthvader
Berichten: 242
Lid geworden op: 13 feb 2011, 15:12
Cash on hand: Locked
Reputation: 0
Usenet: Hitnews
Internet: Caiway
Locatie: Netherlands

Re: Spotlite onder Debian

Bericht door Darthvader » 02 mar 2011, 02:22

Verplaatst naar het Spotlite gedeelte ;)

Gebruikersavatar

Ep Woody
Berichten: 933
Lid geworden op: 17 feb 2011, 14:36
Cash on hand: Locked
Reputation: 0
Locatie: Omgeving Apeldoorn
Been thanked: 5 times
Leeftijd: 33

Re: Spotlite onder Debian

Bericht door Ep Woody » 02 mar 2011, 09:58

Ik heb al meerdere mensen gehoord die Spotlite op Linux hadden geinstalleerd. (zij het op een Red hat achtige distributie.) Het zou dus gewoon moeten werken :)
Voor ondersteuning: klik hier. Probleem niet opgelost, maak dan een nieuw topic aan.


alfadude
Berichten: 8
Lid geworden op: 20 feb 2011, 15:58
Cash on hand: Locked
Reputation: 0

Re: Spotlite onder Debian

Bericht door alfadude » 03 mar 2011, 14:36

Als je de deb extract en eentje voor debian aanmaakt maar toen ik zoiets probeerde kwam ik een segfault tegen.
Nu ga ik het op archlinux nog eens proberen maar ik vind het doodzonde dat het niet gewoon open-source is.

Gebruikersavatar

Ep Woody
Berichten: 933
Lid geworden op: 17 feb 2011, 14:36
Cash on hand: Locked
Reputation: 0
Locatie: Omgeving Apeldoorn
Been thanked: 5 times
Leeftijd: 33

Re: Spotlite onder Debian

Bericht door Ep Woody » 03 mar 2011, 14:40

een .deb is trouwens toch Debian (of Ubuntu, wat gebaseerd is op Debian). Bij mij werkt het op Ubuntu in een keer.
Voor ondersteuning: klik hier. Probleem niet opgelost, maak dan een nieuw topic aan.


robvnl
Berichten: 3
Lid geworden op: 03 mar 2011, 19:46
Cash on hand: Locked
Reputation: 0

Re: Spotlite onder Debian

Bericht door robvnl » 03 mar 2011, 20:10

Hoi, Ik gebruik Ubuntu 10.04 Lucid en heb wat probleempjes met de installatie. Misschien dat iemand kan/wil helpen.

dpkg -i spotlite-amd64.deb
Selecting previously deselected package spotlite.
(Reading database ... 208028 files and directories currently installed.)
Unpacking spotlite (from spotlite-amd64.deb) ...
dpkg: dependency problems prevent configuration of spotlite:
spotlite depends on libqtwebkit4; however:
Package libqtwebkit4 is not installed.
dpkg: error processing spotlite (--install):
dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils ...
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.en_US.utf8.cache...
Processing triggers for python-support ...
Errors were encountered while processing:
spotlite

en libqtwebkit heb ik geinstalleerd.

dpkg --get-selections | grep libqtwebkit
libqtwebkit2.2-cil install

zo te zien is bovenstaande een oudere versie dus heb ik libqtwebkit4 met google opgesnord maar ja.....het blijkt een experimentele versie te zijn. Vandaar dat het natuurlijk niet al in de repos stond. Maar ff met het handje weer:

sudo dpkg -i libqtwebkit4_2.1.0~2011week03-1_amd64.deb
Selecting previously deselected package libqtwebkit4.
(Reading database ... 208031 files and directories currently installed.)
Unpacking libqtwebkit4 (from libqtwebkit4_2.1.0~2011week03-1_amd64.deb) ...
Replacing files in old package libqt4-webkit ...
dpkg: dependency problems prevent configuration of libqtwebkit4:
libqtwebkit4 depends on libqt4-network (>= 4:4.7.0~beta2); however:
Version of libqt4-network on system is 4:4.6.2-0ubuntu5.1.
libqtwebkit4 depends on libqtcore4 (>= 4:4.7.0~beta2); however:
Version of libqtcore4 on system is 4:4.6.2-0ubuntu5.1.
libqtwebkit4 depends on libqtgui4 (>= 4:4.7.0~rc1); however:
Version of libqtgui4 on system is 4:4.6.2-0ubuntu5.1.
libqtwebkit4 depends on libsqlite3-0 (>= 3.7.3); however:
Version of libsqlite3-0 on system is 3.6.22-1.
dpkg: error processing libqtwebkit4 (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
libqtwebkit4

dan verzuip ik dus in de dependencies weer. Ik vond het wel prettig om de packages weer te removen voordat ik mijn hele systeem in de war schop. Iemand suggesties/ideeen? Bedankt.


dennus
Berichten: 1
Lid geworden op: 03 mar 2011, 22:25
Cash on hand: Locked
Reputation: 0

Re: Spotlite onder Debian

Bericht door dennus » 03 mar 2011, 22:47

Ik zit met het zelfde probleem. Kom niet verder dan de persoon hierboven. Is er misschien een handleiding voor install beschikbaar?

Gebruikersavatar

Ep Woody
Berichten: 933
Lid geworden op: 17 feb 2011, 14:36
Cash on hand: Locked
Reputation: 0
Locatie: Omgeving Apeldoorn
Been thanked: 5 times
Leeftijd: 33

Re: Spotlite onder Debian

Bericht door Ep Woody » 04 mar 2011, 11:02

Voor zover ik weet heb je de volgende dependencies nodig :

libqtwebkit4
libopenssl0.9.8
glibc++

Ubuntu 10.04 moet recent genoeg zijn om dat automatisch te installeren.

Code: Selecteer alles

# sudo apt-get update
# sudo apt-get install libqtwebkit4
Voor ondersteuning: klik hier. Probleem niet opgelost, maak dan een nieuw topic aan.


robvnl
Berichten: 3
Lid geworden op: 03 mar 2011, 19:46
Cash on hand: Locked
Reputation: 0

Re: Spotlite onder Debian

Bericht door robvnl » 04 mar 2011, 23:15

robv@earth:~$ sudo apt-get install libqtwebkit4
[sudo] password for robv:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libqtwebkit4 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package libqtwebkit4 has no installation candidate

Ubuntu 10.04 geheel bijgewerkt met laatste updates. Misschien een repository toevoegen in /etc/apt/sources.list ?
De vraag is welke.


robvnl
Berichten: 3
Lid geworden op: 03 mar 2011, 19:46
Cash on hand: Locked
Reputation: 0

Re: Spotlite onder Debian

Bericht door robvnl » 04 mar 2011, 23:32

libqtwebkit4 depends on:
libqt4-network (>= 4:4.7.0~beta2)
libqtcore4 (>= 4:4.7.0~beta2)
libqtgui4 (>= 4:4.7.0~rc1
libsqlite3-0 (>= 3.7.3)

Ik heb een straight forward Ubuntu 10.04 64 bits.
Het probleem zit meer in het feit dat spotlite beta versies gebruikt.
De Ubu 10.04 is een long term support versie waarin de packages erg stable
maar dus vaak ook wat ouder zijn.

Vermoedelijk is dit op te lossen door bovengenoemde versies met google op te
zoeken en gewoon met dpkg te installeren. Waarschijnlijk weer opnieuw andere
dependencies moeten oplossen. Het risico is dat de hele configuratie dusdanig wijzigt
dat het instabiel wordt en andere zaken het niet meer gaan doen.

Zodra ik met clonezilla een nieuw image heb gemaakt ga ik er wel ff mee verder.
Dan restore ik de handel wel als het fout loopt. Ik laat het hier wel weten.

Wat was OpenFTD toch lekker.

Gesloten Vorig onderwerpVolgend onderwerp

Wie is er online

Gebruikers op dit forum: Yahoo [Bot] en 5 gasten

Spot-net.nl Forums : Disclaimer